Broadband-Hamnet™ Forum :: VoIP
Welcome Guest   [Register]  [Login]
 Subject :Asterisk on Pi 3.. 2016-03-21- 12:57:16 
Joined: 2016-03-15- 15:12:39
Posts: 2

I've installed the latest raspbx image on my Pi 3 and have some issues and questions.

All the documentation refers to adding a 'Generic SIP' but the latest version 11.21.0 doesn't list generic as a choice. So is there an alternate such as is Chan_SIP synonymous with Generic SIP?

If I use the raspbx as tftp server the files seem to download but after 'verifying load' the phone shows 'downgrading application', etc and eventually shows tftp failure. Once this occurs it essentially bricks the phone as I cannot access settings afterwards.  I have been able to restore the phone by using a guide I found online, thankfully.

If i put a separate tftp server on the node, TFTPD32, and point the phone to it, the files download, upgrade appplication, and appear to come up as the should showing BBHN across the top of the display and SIP showing in the top right corner. So far this has worked on two phones, a 7940 and a 7940G.

Bottom line issue is the files crashing out when using the raspbx as tftp server. When using separate tftp server phones seem to load correctly but do not dial out. Or at least when I dial from one phone to another it immediately goes to a fast busy.

7940 is connected directly to same node as raspbx, 7940G is on second node. I can ping each phone IP from PC connected to the raspx node.  Each phone is listed as service on its respective node.

I am using the KF5JIM and NG5V Cisco files as posted on the site.

Thanks for any input.

George     K4RQ

IP Logged
 Subject :Re:Asterisk on Pi 3.. 2016-03-21- 13:27:51 
Joined: 2010-01-18- 23:06:23
Posts: 43

Looks like you followed the instructions and have already done some problem solving. TFTP can be tricky. For one thing the older Cisco phones don't run the network interface quickly. A DHCP request isn't always granted and you should check to see if the phone has an IP assigned to it if you fail to connect to Asterisk. Telnet is helpful in getting a view of the phone remotely, or you can punch up the network page from the phone itself.

One thing I didn't see is if the Asterisk server shows you as registered. You can also call your own VM acct to check if the server replies.

A helpful test is to ask for the time, or run an echo test from the diagnostics in the Asterisk setup. In general, there are several steps to get a number working.

Assign an extension and password from asterisk for that phone

Assign a server address and password within the phone to join Asterisk

Test for basic functions like calling your own number or the time/echo services on Asterisk

Depending on what version of Asterisk manager you have, a status screen might have to be refreshed to see if a phone is currently registered. Asterisk usually has a time out and will expire a phone after a period of time if not in use.

Check these out and see if that resolves it.

IP Logged
 Subject :Re:Asterisk on Pi 3.. 2016-03-22- 16:37:36 
Joined: 2016-03-15- 15:12:39
Posts: 2

I retraced all my steps on the RPi and found an error in the dnsmasq settings.  Corrected that and restarted/reconnected everything and had one phone to register. Pointed the phone to tftp on RPi and once phone rebooted all files downloaded correctly and registered on Asterisk.  Brought second phone online and it registered as well. So tfpt problem solved too.   Thanks for the advice.

IP Logged
 Subject :Re:Asterisk on Pi 3.. 2016-03-23- 03:43:24 
Future Astronaut
Joined: 2013-07-17- 12:13:36
Posts: 250
Location: Nederland
Do you mind sharing what exactly was the error in the dnsmasq settings? That way, should someone else has a similar problem in the future we might be able to better assist them?
IP Logged
My opinions and views expressed here are solely my own.
Page # 

Powered by ccBoard