Broadband-Hamnet™ Forum :: VoIP
Welcome Guest   [Register]  [Login]
 Subject :FreePBX Almost Working - Rings but can't answer.. 2016-05-05- 14:58:57 
N9MS
Member
Joined: 2014-11-24- 07:39:08
Posts: 15
Location

I followed the instructions on the video by KF5JIM. The phones can call each other and the phones ring BUT you can't talk. I get a hangup. 

Here is a portion of the Asterisk log with the error. Any idea how I can correct this? I read the wiki page but I'm not sure what I should do next.

Asterisk Logfile



IP Logged
 Subject :Re:FreePBX Almost Working - Rings but can't answer.. 2016-05-05- 15:48:00 
N9MS
Member
Joined: 2014-11-24- 07:39:08
Posts: 15
Location

I forgot to mention that FreePBX was working great on my home network. The phones stopped talking to each other when I connected to the Mesh network. 

IP Logged
 Subject :Re:FreePBX Almost Working - Rings but can't answer.. 2016-05-06- 22:20:59 
N9MS
Member
Joined: 2014-11-24- 07:39:08
Posts: 15
Location

I figured it out -- actually I found a similar problem on Stack Exchange and there was an answer to a similar problem and  that fixed my problem.

The answer was to check the file /etc/asterisk/sip_nat.conf and be sure it was set like:
localnet=192.168.1.0/255.255.255.0

Well that is wrong for the Mesh but my file contained absolutely nothing -- it was blank.

I opened up the file and put in:
localnet=10.64.68.2/255.255.255.248

I then rebooted the system and now it WORKS!! I'm getting voice over my Raspberry PI/FreePBX system!!

I don't understand how Asterisk could ring the phones but not complete the call but this seems to be an important file that in my case needed to be updated.'

Mike N9MS

 

IP Logged
Page # 


Powered by ccBoard


SPONSORED AD: