Broadband-Hamnet™ Forum :: General
Welcome Guest   [Register]  [Login]
 Subject :Port forwarding for Echolink repeater node.. 2016-05-25- 19:05:57 
Joined: 2016-05-25- 03:24:25
Posts: 1

Hi All,

I have a 70cm repeater at a remote site running OpenRepeater on a raspberry Pi. The Pi has Echolink enabled and the network back to the internet gateway is via HamNet nodes on WRT54's.

The topology is made up of 3 nodes as follows:

1 node at the repeater site, 1 node at my QTH (link) and finally a node connected to my PC.

Internet services are connected to the QTH link node and is available across the mesh. Another Echolink node sits on my home LAN and works, so I know port forwarding is ok through my home network router.

I have added port forwarding for TCP/UDP 5198-5200 on all of the nodes but to date I have had no success in getting it working.

Has anyone in Hamnet land got Echolink running on the mesh and if so what are your settings?

Do I need to enable mesh services at the repeater end and or can the localnode setting be used on one or more of the nodes?

Kind regards



IP Logged
 Subject :Re:Port forwarding for Echolink repeater node.. 2016-05-25- 22:41:31 
Future Astronaut
Joined: 2013-07-17- 12:13:36
Posts: 250
Location: Nederland

If you are working in x-host DMZ, then you need not forward ports on the BBHN nodes. However, if your node is set to NAT mode, then you must forward the needed ports on the BBHN node the Raspberry Pi is plugged into. You do not need to enable mesh services unless you want the service advertised (clickable) to allow users to access it via a web browser.

The main problem I see is that you have another Echolink node on your home LAN is that you are forwarding ports to that particular Echolink node too. If a packet were to arrive at your home's IP Address, your router will not be able to know which of the two internal IP addresses it should be forward the information to.

Because of that, try disconnecting the Echolink node on your home network. Plug the one sitting on your mesh network in to the same BBHN node as the one advertizing internet onto the mesh. Forward UDP/5198-5199 and TCP/5200 to that particular node from your home network. And try again. If that works, then try moving the Mesh Eholink node out to another node.

Hope this helps!

IP Logged
My opinions and views expressed here are solely my own.
Page # 

Powered by ccBoard